cdnjs website & API erroring for some libraries
Incident Report for cdnjs
Resolved
We are confident at this time that we have resolved the errors seen with the website & API, both are now handling library requests correctly.
Posted Jun 12, 2020 - 12:18 UTC
Monitoring
The cdnjs website and API are now both using updated packages metadata, allowing them to correctly respond to requests for libraries without error. We will continue to monitor both the API and website to ensure this doesn't happen again.
Posted Jun 12, 2020 - 11:15 UTC
Update
The cdnjs API is now correctly responding to library requests, however, we are still working to resolve the issue present on the website.
Posted Jun 12, 2020 - 10:30 UTC
Identified
We have identified the source of the failure, the metadata used for the website and API for packages data was unable to generate correctly, resulting in the data used being corrupted. We are working to mitigate this and regenerate the data.
Posted Jun 12, 2020 - 09:25 UTC
Investigating
We are aware of reports that some libraries on the cdnjs website and API are resulting in an error response. We have notified our team and are looking into the root cause of this issue.
Posted Jun 12, 2020 - 08:30 UTC
This incident affected: API (api.cdnjs.com) and Main Website (cdnjs.com).