Resources not loading - 404/CORS
Incident Report for cdnjs
Resolved
We and Cloudflare are happy to say that the CDN is now performing normally.
Posted 10 months ago. Dec 28, 2018 - 20:30 UTC
Update
We believe that the CDN is now serving all requests with valid responses. We sincerely apologise for the long delay in resolving this issue. We will continue to monitor the situation for a while longer to confirm all is okay.
Posted 10 months ago. Dec 28, 2018 - 12:00 UTC
Monitoring
Cloudflare have now identified the failing origin servers and they have been removed from the load balancer. CDN responses should now return to normal and cdnjs/Cloudflare will continue to monitor this.
Posted 10 months ago. Dec 27, 2018 - 12:15 UTC
Update
To assist Cloudflare in identifying bad origin servers for the CDN, please post any failed requests on our GitHub mega-issue with full request and response headers along with the resource URL that failed: https://github.com/cdnjs/cdnjs/issues/13165
Posted 10 months ago. Dec 26, 2018 - 12:45 UTC
Update
Cloudflare are now handling this issue and actively looking to resolve it as it is a failure of their infrastructure behind cdnjs that is causing this issue. They apologise for any delay due to engineering staff being away on holiday leave.
Posted 10 months ago. Dec 25, 2018 - 23:30 UTC
Update
We are aware that a higher percentage of requests are beginning to fail now. We apologise for the delay in resolving this. Please continue to post full request/response headers on the GitHub mega-issue to assist Cloudflare in resolving this: https://github.com/cdnjs/cdnjs/issues/13165
Posted 10 months ago. Dec 23, 2018 - 18:30 UTC
Identified
We believe we have identified the issue relating to the minority of requests that are receiving a bad response. We have alerted Cloudflare to this and are currently awaiting their response to resolve this.
Posted 10 months ago. Dec 23, 2018 - 11:00 UTC
Update
To help us with investigating this issue we have created a GitHub mega-issue. Please post any failed requests will full request/response headers and the resource URL that failed: https://github.com/cdnjs/cdnjs/issues/13165
Posted 10 months ago. Dec 22, 2018 - 21:15 UTC
Investigating
We have been made aware that our CDN is in a small number of requests giving an invalid response that is a 404 with missing CORS headers. We are currently investigating this and will post an update here shortly.
Posted 10 months ago. Dec 22, 2018 - 21:00 UTC
This incident affected: CDN Service (cdnjs.cloudflare.com).