SRI hashes changed on multiple libraries
Incident Report for cdnjs
Resolved
At this time we believe the fix to restore file content and SRI hashes is working as expected.
Posted Aug 04, 2023 - 15:33 UTC
Monitoring
A backfill has been completed that is believed to have restored files to their previous states, with the SRI hashes reverted to what they were prior to this incident. We'll continue to monitor for reports of any hash mismatches, which should be reported in the issue on GitHub at https://github.com/cdnjs/cdnjs/issues/14210
Posted Aug 02, 2023 - 18:26 UTC
Identified
We are aware of an issue impacting multiple libraries where SRI hashes have changed. We have found the cause of the change to the file contents/hashes and are actively working to restore the previous contents/hashes. No files on the CDN have been compromised, the contents/hashes have changed due to libraries being reprocessed with different minification logic. We are tracking this on GitHub in https://github.com/cdnjs/cdnjs/issues/14210
Posted Aug 01, 2023 - 18:22 UTC
This incident affected: CDN Service (cdnjs.cloudflare.com).