API returning 502 responses

Incident Report for cdnjs

Resolved

This incident has been resolved.
Posted May 20, 2022 - 21:45 UTC

Monitoring

At this time the API is now returning valid responses for all requests. We will continue to monitor the situation to ensure this remains true.
Posted May 20, 2022 - 20:31 UTC

Update

We are continuing to investigate the 502 issue with the API. It appears to be impacting a limited subset of requests at this time.
Posted May 20, 2022 - 11:45 UTC

Investigating

We are aware that the cdnjs API is returning 502 responses for many requests. We are investigating this issue.

(Edit: This incident has been back-dated to the believed initial starting point of impact for requests. Incident was initially declared at 11:30 UTC.)
Posted May 20, 2022 - 02:00 UTC
This incident affected: API (api.cdnjs.com).