Library versions missing from website & API
Incident Report for cdnjs
Resolved
We are now confident the fix is working as expected. The cdnjs website and API are now showing libraries and their versions correctly.
Posted Dec 30, 2019 - 17:19 UTC
Monitoring
We have now implemented a fix and believe that packages should now be showing correctly on the cdnjs website and via the API. We will continue to monitor this whilst the caches clear to ensure this issue is no longer present.
Posted Dec 30, 2019 - 15:35 UTC
Identified
We have identified the issue as a fault within our package generation script that feeds cdnjs repository information to our website & API. We are tracking this issue on GitHub: https://github.com/cdnjs/cdnjs/issues/13654
Posted Dec 30, 2019 - 15:33 UTC
Investigating
We have been made aware of an issue with the cdnjs website that means certain library pages are not showing, with an error message "version not found!" shown instead. Further, it appears that on the same libraries, their API responses do not contain the correct versions. This does not affect the libraries available on the CDN, cdnjs.cloudflare.com.
Posted Dec 30, 2019 - 09:59 UTC
This incident affected: API (api.cdnjs.com) and Main Website (cdnjs.com).